Review Request 129648: New widget: tooltip that contains another widget

Christoph Feck cfeck at kde.org
Wed Dec 21 17:23:24 UTC 2016


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/129648/#review101538
-----------------------------------------------------------




src/ktooltipwidget.cpp (line 94)
<https://git.reviewboard.kde.org/r/129648/#comment67980>

    'auto' is C++11, too (if used as a type). Please use explicit types here.
    
    Especially with 'screen' I was thinking this is the screen number. Suggest to rename it to 'screenRect' or 'screenGeometry' to make it clearer.
    
    I hope the mouse is actually at the screen this function assumes it is :)


- Christoph Feck


On Dec. 21, 2016, 6:19 p.m., Elvis Angelaccio wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/129648/
> -----------------------------------------------------------
> 
> (Updated Dec. 21, 2016, 6:19 p.m.)
> 
> 
> Review request for KDE Frameworks, Ben Cooksley, Christoph Feck, and Martin Gräßlin.
> 
> 
> Repository: kwidgetsaddons
> 
> 
> Description
> -------
> 
> This new widget is based on the KToolTip code that is duplicated across multiple products: at least Dolphin, systemsettings, kinfocenter, ktp-contact-list.
> 
> Rationale: with a single class in frameworks, it will be possible to apply features/fixes only once. See for example the comments in https://phabricator.kde.org/D3112
> 
> A new feature that the old code doesn't have is the delayed hide: this makes it possible to actually use the widget shown in the tooltip.
> 
> 
> Diffs
> -----
> 
>   autotests/CMakeLists.txt ffcce3a046ec98b07c4677578f6bc997de1ef16b 
>   autotests/ktooltipwidgettest.h PRE-CREATION 
>   autotests/ktooltipwidgettest.cpp PRE-CREATION 
>   src/CMakeLists.txt de0a8d965f1541d5ffeec93d1aa06600b0b9c138 
>   src/ktooltipwidget.h PRE-CREATION 
>   src/ktooltipwidget.cpp PRE-CREATION 
>   tests/CMakeLists.txt fcb348b1ae9d4270468c3f9003c5ba5f3903db84 
>   tests/ktooltipwidget_test.h PRE-CREATION 
>   tests/ktooltipwidget_test.cpp PRE-CREATION 
> 
> Diff: https://git.reviewboard.kde.org/r/129648/diff/
> 
> 
> Testing
> -------
> 
> Manual test works both in X11 and Wayland. Unit tests pass.
> 
> Ported Dolphin locally to this new class, everything seems to work (and this will fix bug [#352276](https://bugs.kde.org/show_bug.cgi?id=352276) and [#371223](https://bugs.kde.org/show_bug.cgi?id=371223)).
> 
> 
> Thanks,
> 
> Elvis Angelaccio
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20161221/ae18e9ab/attachment.html>


More information about the Kde-frameworks-devel mailing list