Review Request 119607: Support for ".hidden" files

David Faure faure at kde.org
Wed Sep 17 20:08:13 UTC 2014



> On Sept. 14, 2014, 3:27 p.m., Frank Reininghaus wrote:
> > I've added some comments inline. You should wait for David's feedback though.
> > 
> > BTW, do other platforms, which support ".hidden" files already, only support full file names in that file, or can you add wildcards (such as "*~", "*.log", etc.) as well?
> 
> Bruno Nova wrote:
>     I've tested Nautilus and Thunar (which support ".hidden"), and it looks like wildcards are not supported there. Only full names work.
>     And leading and trailing slashes are not ignored (which makes sense, because files may actually have leading/trailing spaces). This patch has the same behavior.
>     
>     It would be a nice feature for all file managers, but it would mean more overhead.

Oops I should have read old comments before adding mine.

OK then - let's not do wildcards, for the benefit of speed, indeed.


> On Sept. 14, 2014, 3:27 p.m., Frank Reininghaus wrote:
> > src/core/kfileitem.h, line 262
> > <https://git.reviewboard.kde.org/r/119607/diff/2/?file=301216#file301216line262>
> >
> >     Since we probably do not want to make it possible that all users of this class can make items "hidden", I'm not sure if this should be part of KFileItem's public API.

I don't have an issue with that. Gives more possibilities to the app (or file dialog) etc.


> On Sept. 14, 2014, 3:27 p.m., Frank Reininghaus wrote:
> > src/core/kcoredirlister.cpp, line 1218
> > <https://git.reviewboard.kde.org/r/119607/diff/2/?file=301215#file301215line1218>
> >
> >     const
> 
> Bruno Nova wrote:
>     What do you mean? `filesToHide` should be `const`?
>     (I thought I had added this comment before, but I'm not seeing it)

Yes, make local vars const if they are not getting modified. Helps readability and helps avoiding unnecessary detach()s, e.g. when calling begin().


- David


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/119607/#review66475
-----------------------------------------------------------


On Sept. 14, 2014, 7:32 p.m., Bruno Nova wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://git.reviewboard.kde.org/r/119607/
> -----------------------------------------------------------
> 
> (Updated Sept. 14, 2014, 7:32 p.m.)
> 
> 
> Review request for KDE Frameworks and David Faure.
> 
> 
> Bugs: 64740 and 246260
>     https://bugs.kde.org/show_bug.cgi?id=64740
>     https://bugs.kde.org/show_bug.cgi?id=246260
> 
> 
> Repository: kio
> 
> 
> Description
> -------
> 
> This adds support for *.hidden* files to KDE.
> 
> When listing a directory, the files/folders listed in the *.hidden* file will be hidden, unless the user has chosen to show hidden files.
> 
> This patch was initially based on the patch provided by Mark in Bug #246260.
> 
> 
> Diffs
> -----
> 
>   src/core/kcoredirlister.h e6ba2ac 
>   src/core/kcoredirlister.cpp a31d629 
>   src/core/kfileitem.h bebc241 
>   src/core/kfileitem.cpp 74dc069 
> 
> Diff: https://git.reviewboard.kde.org/r/119607/diff/
> 
> 
> Testing
> -------
> 
> Built and tested the patch in Project Neon.
> Dolphin was still using KDE4/Qt4 version of the library, so I only tested using the desktop folder widget, and "folder desktop".
> It worked correctly when I pointed it to "~" and "~/Desktop" (I added ".hidden" there).
> However, it didn't work when I pointed it to the "Desktop folder" (the default option, not the custom location "~/Desktop").
> More testing is required.
> 
> The version for KDE4/Qt4 submitted to Bug #246260 was tested in Kubuntu 14.04, and it worked everywhere I tested (Dolphin, open/save dialogs, folder widget and detailed/tree view in Dolphin).
> It wasn't an intensive test, though.
> 
> 
> Thanks,
> 
> Bruno Nova
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20140917/268b50e2/attachment.html>


More information about the Kde-frameworks-devel mailing list