Review Request 115101: add signal KMessageWidget::hideAnimationFinished()
Dominik Haumann
dhaumann at kde.org
Mon Jan 20 16:12:43 UTC 2014
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://git.reviewboard.kde.org/r/115101/
-----------------------------------------------------------
(Updated Jan. 20, 2014, 4:12 p.m.)
Review request for KDE Frameworks, Albert Astals Cid and Aurélien Gâteau.
Changes
-------
Rename hide/showAnimationRunning to is{Hide,Show}AnimationRunning
Repository: kwidgetsaddons
Description
-------
This patch adds the signal KMessageWidget::hideAnimationFinished(), indicating that the hide animation is finished.
This is required by Kate Part's passive notification system, since the next pending message is shown only after the hide animation is finished.
Right now, Kate Part launches a timer of 500ms (these 500 ms are used by kmessagewidget's animatedHide()) to estimate when the animation is finished.
This signal cannot be replaced by e.g. deriving KMessageWidget, since QHideEvent is also sent in case of the parent widget is hidden.
The same holds for animatedShow(): Emit signal showAnimationFinished() when the show animation is finished.
Besides that, the two convenience functions
bool hideAnimationRunning() const;
bool showAnimationRunning() const;
are also added to check the current state of the animations. This is also required by Kate Part in order to wait until an animation is finished before starting a new one.
Diffs (updated)
-----
autotests/CMakeLists.txt 6ea9d12
autotests/kmessagewidgetautotest.h PRE-CREATION
autotests/kmessagewidgetautotest.cpp PRE-CREATION
src/kmessagewidget.h a17bccf
src/kmessagewidget.cpp deb82a3
Diff: https://git.reviewboard.kde.org/r/115101/diff/
Testing
-------
In Kate Part, not commited so far, though.
Thanks,
Dominik Haumann
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20140120/b65e937d/attachment.html>
More information about the Kde-frameworks-devel
mailing list