New framework to review: KPackage
Marco Martin
notmart at gmail.com
Mon Dec 22 14:33:25 UTC 2014
On Wednesday 10 December 2014, David Edmundson wrote:
> The binary is called kpackagetool. Given the complications we've had with
> frameworks co-installability does it make sense to call it kpackagetool5?
>
> The class name in kpackagetool/kpackagetool.cpp should probably be renamed
>
> Documentation at the top of PackageLoader should avoid saying Plasma quite
> so much
done.
> commented line at 773 of package.cpp looks concerning. I think it is just
> dead code.
yep, a signal that used to exist in plasma1, removed
> Installation command of plasmoids.knsrc are wrong (in fact they're wrong
> for current plasmapkg)
> Should kpackage even be providing this file? I think it should be with the
> plasmoid definition.
agree, shouldn't be there: removed.
> IMHO PackageJob probably shouldn't set a parent to the packagestructure.
> Otherwise if you create a PackageStructure on the stack then call
> install/uninstall it will delete the job before it's finished.
should be safe to don't have any parent since kjobs shuold delete themselves
iirc? (changed to that)
> There's a Qt5 TODO on PackageJobThread::removeFolder
changed to just use QDir::removeRecursively()
--
Marco Martin
More information about the Kde-frameworks-devel
mailing list