Review Request 113586: More general warning cleanups

Commit Hook null at kde.org
Mon Nov 4 19:58:26 UTC 2013


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/113586/#review43011
-----------------------------------------------------------


This review has been submitted with commit 7fcde34e2cb197250e46e935d6948a1582955567 by Alex Merry to branch frameworks.

- Commit Hook


On Nov. 3, 2013, 5:24 p.m., Alex Merry wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/113586/
> -----------------------------------------------------------
> 
> (Updated Nov. 3, 2013, 5:24 p.m.)
> 
> 
> Review request for KDE Frameworks.
> 
> 
> Repository: kdelibs
> 
> 
> Description
> -------
> 
> Another bunch of fairly obvious warning fixes; this should be pretty much all the noise that can easily be dealt with.  Everything else requires either more consideration or the enabling of KDE_NO_DEPRECATED.  Speaking of which, several of the fixes get us closer to kf5 actually compiling with that defined.
> 
> 
> Remove call to KUrlRequester::fileDialog() from test
> 
> This is (a) unnecessary and (b) deprecated.
> 
> KIO::RenameDialog: use KIO::suggestName instead of local method
> 
> Also, wrap the local implementation of suggestName in KDE_NO_DEPRECATED,
> like its declaration.
> 
> Remove use of deprecated form of KRecentDocument::add
> 
> 
> KCategoryDrawerV3 -> KCategoryDrawer in KPluginSelector
> 
> 
> Mark KPluginInfo::fromServices as deprecated
> 
> It is simply the multiple-at-once version of the deprecated KPluginInfo
> constructor that takes a KService.
> 
> Mark unused (except for debugging) args with Q_UNUSED
> 
> 
> Wrap test of deprecated method in KDE_NO_DEPRECATED
> 
> The test will not compile with KDE_NO_DEPRECATED set...
> 
> Do not compile KComboBox::setUrlDropsEnabled if KDE_NO_DEPRECATED is set
> 
> It calls a deprecated method, and its declaration is wrapped in
> KDE_NO_DEPRECATED as well.
> 
> KAuth: handle QtTraceMsg messages
> 
> We just treat them like debug messages.
> 
> Fix warnings in Solid UDisks2 backend
> 
> Make it explicit that UDisks2 does not support Keyboard or
> PointingDevice.  Also make the switch statement easier to read.
> 
> Wrap assertion function in #ifndef QT_NO_DEBUG
> 
> This function is only used in a Q_ASSERT, so prevent it from being
> compiled if assertions are disabled.
> 
> 
> Diffs
> -----
> 
>   staging/kio/src/filewidgets/kencodingfiledialog.cpp c6c159fb016b8b8b1a7caa20d814f62e1989bb57 
>   staging/kio/src/filewidgets/kfilewidget.cpp 48215315ea1a4c335992185735b8a717b8d5add6 
>   staging/kio/src/widgets/renamedialog.cpp 0830c90a199a780e79966d3220e595866c8f7b96 
>   staging/kio/tests/kurlrequestertest_gui.cpp 948085f090e3c388246ae7b11ae348a089a5893c 
>   tier1/itemmodels/src/kselectionproxymodel.cpp df83ae6c51edcdf01d1d16b351a63507d6a5a982 
>   tier1/solid/src/solid/backends/udisks2/udisksdeviceinterface.h 43a1b6f896834e9fe9e94e9580ff5845036aa754 
>   tier2/kauth/src/backends/dbus/DBusHelperProxy.cpp ee44d930eddd647e8ad5d1cf20097a1b8a719efa 
>   tier2/kauth/src/kauthhelpersupport.cpp 8eaa97dead64e745ab9e4e674ffa02f3d4b72bdb 
>   tier2/kcompletion/src/kcombobox.cpp 4043ea5448a67c01751cc849d56c3fdd4d61035c 
>   tier2/kcompletion/tests/klineedittest.cpp 233bdd3afd8b489e9f32f81ac89b57114948c034 
>   tier3/kservice/src/kbuildsycoca/kmimeassociations.cpp dfd2a6d83c637215219c7fd928dcd4fb37097ddf 
>   tier3/kservice/src/services/kplugininfo.h 2555ef27d1ccc2fa58a905175bdcefab4e6491ea 
>   tier3/kservice/src/services/kplugininfo.cpp e19ae7e3fcadfbcadfcecea3795a0d9afad09753 
>   tier3/xmlgui/src/kxmlguifactory.cpp d2980f45fe8e32f1b4aa535661eb002c69969698 
>   tier4/kcmutils/src/kpluginselector.cpp 768dbf33b136b79f3cab4c6f09e84d2a4378a022 
>   tier4/kcmutils/src/kpluginselector_p.h de42f03a99ba35e4c43927a7e2c07fc3a541de5a 
> 
> Diff: http://git.reviewboard.kde.org/r/113586/diff/
> 
> 
> Testing
> -------
> 
> Builds; tests pass.
> 
> 
> Thanks,
> 
> Alex Merry
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20131104/262e6c22/attachment.html>


More information about the Kde-frameworks-devel mailing list