Add step parameter to DoubleInput QInputDialog
David Gil Oliva
davidgiloliva at gmail.com
Fri May 10 21:00:31 UTC 2013
2013/5/10 David Faure <faure at kde.org>
> On Wednesday 08 May 2013 17:26:17 David Gil Oliva wrote:
>
> > Therefore, I think that it would be best to add a static method called
> > getItemFromListView. What do you think?
>
> Option 1: adding getItemFromListView (the name looks a bit odd)
> Option 2: adding a getItem overload that takes an InputDialogOptions
> parameter, so that this will be ready for more options if any, in the
> future.
>
There's something odd about the second one. I could write a getItem
overload with a InputDialogOptions parameter, but the value of that
parameter could be:
enum InputDialogOption {
NoButtons = 0x00000001,
UseListViewForComboBoxItems = 0x00000002,
UsePlainTextEditForTextInput = 0x00000003
};
The third one is for the new getMultiLineText method.
Actually, only the second one has something to do with the other
static-getItem-with-listView method. Therefore it turns out the aim is not
to have a listView in getItem, but to be able to use any existing option,
even when they don't make any sense for the getItem method. I find it weird
and counter-intuitive.
> Option 3: porting coded to the multi-line call (constructor,
> setComboBoxItems,
> setOptions).
>
Sorry that I insist, but with so many messages I don't want my question to
get buried down. I don't understand this third option and I'd need a little
explanation...
Thank you so much
David Gil
www.hackingastrology.net
>
> In my opinion option 2 is best if not too ugly (not sure where to add the
> additional argument, depends how many default values there are etc.),
> otherwise option 3 (depending on how many calls to getItem we actually
> have...).
>
> --
> David Faure, faure at kde.org, http://www.davidfaure.fr
> Working on KDE, in particular KDE Frameworks 5
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-frameworks-devel/attachments/20130510/f747e721/attachment.html>
More information about the Kde-frameworks-devel
mailing list