D21684: Hypothesis test: Dock and View for t test and z test

Stefan Gerlach noreply at phabricator.kde.org
Tue Jun 11 15:07:28 BST 2019


sgerlach added inline comments.

INLINE COMMENTS

> HypothesisTest.cpp:97
> +}
> +
> +void HypothesisTest::setSignificanceLevel(QVariant alpha) {

with or without "()"?

> HypothesisTest.cpp:102
> +
> +void HypothesisTest::setTailType(HypothesisTest::TailType tailType) {
> +    d->tail_type = tailType;

QString::isEmpty()

> HypothesisTest.cpp:160
>  HypothesisTestPrivate::HypothesisTestPrivate(HypothesisTest* owner) : q(owner) ,
>      dataModel(new QStandardItemModel) ,
> +    horizontalHeaderModel(new QStandardItemModel) ,

please indent to make it more readable.

> HypothesisTest.cpp:166
>  
>  HypothesisTestPrivate::~HypothesisTestPrivate() {

better "t_value"?

> HypothesisTest.cpp:171


why 9?

> HypothesisTest.cpp:786


This header text should be defined separately to make the code more readable.

> HypothesisTestView.cpp:62
> +    m_testName(new QLabel()),
> +    m_statsTable(new QLabel()),
> +    m_resultView(new QListView(this)) {

please add TODO comments for missing implementations.

> HypothesisTestView.h:8


The indentation looks strange here.

REPOSITORY
  R262 LabPlot

REVISION DETAIL
  https://phabricator.kde.org/D21684

To: devanshuagarwal, sgerlach, asemke
Cc: kde-edu, #labplot, narvaez, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20190611/63253594/attachment.html>


More information about the kde-edu mailing list