D18280: Locking plot to be moved or zoomed
Alexander Semke
noreply at phabricator.kde.org
Sat Jan 19 09:04:02 GMT 2019
asemke added inline comments.
INLINE COMMENTS
> Worksheet.h:81
> + CartesianPlotActionMode cartesianPlotActionMode();
> + bool lockPlot();
> + void setCartesianPlotActionMode(CartesianPlotActionMode mode);
isLocked() is a better name.
> Worksheet.h:83
> + void setCartesianPlotActionMode(CartesianPlotActionMode mode);
> + void setLockPlot(bool lock);
> +
setLocked(bool) is a better name.
> WorksheetPrivate.h:78
> QString theme;
> + bool lockPlot{false};
> + Worksheet::CartesianPlotActionMode cartesianPlotActionMode{Worksheet::CartesianPlotActionMode::ApplyActionToSelection};
we don't need to mention 'Plot' in the member variable of the plot. Let's simply use 'bool locked'.
REVISION DETAIL
https://phabricator.kde.org/D18280
To: Murmele, asemke
Cc: kde-edu, Murmele, narvaez, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20190119/0b327afa/attachment.html>
More information about the kde-edu
mailing list