D17783: Add configuration menu in small numbers activity to support multiple domino types

Johnny Jazeix noreply at phabricator.kde.org
Mon Jan 14 12:25:25 GMT 2019


jjazeix added inline comments.

INLINE COMMENTS

> Gletters.qml:125
>  
> +        //created to retrive available menu modes for domino configurations
> +        Domino {

retrieve

> Gletters.qml:144
>                      }
> +                    property variant availableModes: invisibleDomino.menuModes
> +                    property alias modeBox: modeBox

var, no variant (it is obsolete: http://doc.qt.io/qt-5/qml-variant.html)

> Gletters.qml:171
> +                    Column {
> +                        spacing: 10
> +                        width: parent.width

can it be added directly in the other Flow and make the items visible or not? Else, if we, for some reason, need to have a common parameter for multiple activities, we won't have to duplicate the code

> Gletters.qml:191
>              onLoadData: {
> -                if(dataToSave && dataToSave["locale"]) {
> -                    background.locale = dataToSave["locale"];
> -                    activity.uppercaseOnly = dataToSave["uppercaseMode"] === "true" ? true : false;
> +                if (activity.activityName == "gletters") {
> +                    if(dataToSave && dataToSave["locale"]) {

would be better to get it from the visible property if you change the above behaviour.

> Gletters.qml:224
> +                    if (newMode !== activity.dominoMode) {
> +                    activity.dominoMode = newMode;
> +                    dataToSave = {"mode": activity.dominoMode};

indentation

> Smallnumbers2.qml:32
> +    configurationButtonVisible: true
> +    property string activityName: "smallnumbers2"
> +    property string dominoMode: "dot"

"property string" is not needed if it is defined in Gletters.qml

> Domino.qml:82
> +    //menu modes for setting different types for domino
> +    readonly property variant menuModes : [
> +        { "text": qsTr("Dots"), "value": "dot" },

variant is deprecated, var should be used

REPOSITORY
  R2 GCompris

REVISION DETAIL
  https://phabricator.kde.org/D17783

To: AkshayCHD, #gcompris_improvements
Cc: jjazeix, kde-edu, #gcompris_improvements, harrymecwan, ganeshredcobra, nityanandkumar, echarruau, rahulyadav, narvaez, scagarwal, apol, timotheegiet, hkaelberer, bcoudoin
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20190114/513d83d4/attachment.html>


More information about the kde-edu mailing list