D16429: [WIP] Rewrite of Scheduler planning

Eric Dejouhanet noreply at phabricator.kde.org
Fri Nov 9 08:43:05 GMT 2018


TallFurryMan updated this revision to Diff 45158.
TallFurryMan added a comment.


  Still WIP, not entirely rebased, but shows were the rewrite is at.
  UI is probably prettier than it was before, but that won't help the first Ekos tab.
  Altitude sorting is clarified with the UI rework, but clicking the sort button is not stable.
  Row selection is still to be fixed.
  All schedule consolidation issues are now fixed!
  I'm nearly finished, still quite a bit of testing needed.
  
  - Fix move still possible just after enabling sort.
  - Fix jobs not reset after move, refactor evaluation.
  - Optimize UI refresh with manual content update after cell assignment refactoring.
  - Refactor cell assignment when adding a new job or editing one.
  - Reorder jobs automatically when "Sort Jobs by Altitude and Priority" is enabled.
  - Add a few assertions.
  - Fix management of score value zero, which is acceptable for observation.
  - Rewrite dark sky score calculation to consider seconds at most when comparing times.
  - Rewrite altitude score calculation to not modify the job startup time, move logs to caller.
  - Fix altitude cutoff issue, rewrite calculateAltitudeTime.
  - Fix altitude cutoff issue, rewrite calculateAltitudeScore.
  - Fix stability of culmination search, rewrite calculateCulminationOffset.
  - Rewrite getDarkSkyScore to use an argument date.
  - Fix job reordering algorithm.
  - Fix reset and evaluation of jobs when they are moved in the list.
  - Rewrite Moon separation algorithm.
  - Rewrite total score consolidation.
  - Adjust weather score documentation.
  - Integrity fixes for startup and estimated times of SchedulerJob.
  - Remove logs for astronomical twilight.
  - Fix for decimale display in altitude constraint log.
  - Rewrite findAltitude to duplicate code.
  - Rewrite calculateAltitudeTime.
  - Make getDarkSkyScore const on Scheduler.
  - Rewrite calculateCulmination to duplicate code.
  - Make getWeatherScore const on Scheduler.
  - Rewrite score calculations to duplicate code.
  - Rewrite planning algorithm.
  - Rewrote algorithm documentation.
  - Fixes from Phabricator comments.
  - Remove warning for infinite loop, and convert some logs in imaging duration.
  - Refresh imaging duration after sequencing when job has repeats or loops.
  - Add invariants for imaging time estimation, and fix some issues regarding duration.
  - Fix rising/setting determination, hours are already considering LST and are in [0,24[ !!
  - Add altitude and lead time columns to job table.
  - Fixed unused minimum altitude to -90 instead of -1.
  - Added lead time from a previous job to scheduler job.
  - fixup! Fix rising/setting determination, hours are already considering LST and are in [0,24[ !!
  - fixup! Add altitude and lead time columns to job table.
  - Change the job sorting predicate to consider rise/set, introduce manual sort and reset count when re-evaluating manually.

REPOSITORY
  R321 KStars

CHANGES SINCE LAST UPDATE
  https://phabricator.kde.org/D16429?vs=44805&id=45158

BRANCH
  improve__visual_sort (branched from master)

REVISION DETAIL
  https://phabricator.kde.org/D16429

AFFECTED FILES
  kstars/ekos/scheduler/scheduler.cpp
  kstars/ekos/scheduler/scheduler.h
  kstars/ekos/scheduler/scheduler.ui
  kstars/ekos/scheduler/schedulerjob.cpp
  kstars/ekos/scheduler/schedulerjob.h

To: TallFurryMan, mutlaqja, wreissenberger
Cc: yurchor, kde-edu, narvaez, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20181109/76633156/attachment.html>


More information about the kde-edu mailing list