D17731: Select curve only, when clicked near curve

Alexander Semke noreply at phabricator.kde.org
Tue Dec 25 15:31:08 GMT 2018


asemke added a comment.


  we mostly used the camel case naming convention. You seem to mix different conventions like in xdistsquare (instead of xDistSquare) and lower_index(instead of lowerIndex). Can you please unify the naming?
  
  Furthermore, we'll need to extend this logic to datetime data type where we store QDateTime instead of doubles in the column. But let's finalize this patch firs and extend/adjust the logic after that.

INLINE COMMENTS

> XYCurve.cpp:1694
> + */
> +// TODO: testing if it is faster than calculating log2.
> + int XYCurve::calculateMaxSteps (unsigned int value) {

this is a very valid question :-)

> XYCurve.cpp:2371
> +
> +	if(!on){
>  		m_hovered = false;

this block can be simplified to

  m_hovered = on;
  on ? emit q->hovered() : emit q->unhovered();
  update()

REVISION DETAIL
  https://phabricator.kde.org/D17731

To: Murmele, asemke
Cc: yurchor, kde-edu, Murmele, narvaez, apol
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-edu/attachments/20181225/6a812667/attachment.html>


More information about the kde-edu mailing list