[kde-edu]: Link error in kgeography under OSX

Pino Toscano toscano.pino at tiscali.it
Tue Sep 19 18:29:22 CEST 2006

Alle 18:16, martedì 19 settembre 2006, Jason Harris ha scritto:
> Linking CXX executable script.app/Contents/MacOS/script
> /usr/bin/ld: Undefined symbols:
> QDomDocument::setContent(QIODevice*, QString*, int*, int*)
> [...]
> I tried adding "${KDE4_KXMLCORE_LIBS}" to the target_link_libraries()
> list in kgeography/src/CMakeLists.txt, but this was little more than a
> guess.  The above errors imply that the QtXml library isn't being
> linked, so I hoped adding the above variable would do it.  But I get the
> same error.

Of course, kxmlcore is not the Qt library for XML. Try using 
${QT_QTXML_LIBRARY} in the larget_link_libraries() and see what could happen.

Pino Toscano
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.kde.org/pipermail/kde-edu/attachments/20060919/560835d6/attachment.pgp 

More information about the kde-edu mailing list