Plugin development - old library version keeps being used after recompiling

David Lerch alemariusnexus at gmail.com
Sat Jan 16 07:49:58 GMT 2021


Hey,

I'm starting development of a ThumbCreator-based thumbnailer plugin
based on kffmpegthumbnailer
(https://github.com/dirkvdb/ffmpegthumbnailer/tree/master/kffmpegthumbnailer)
and ffmpegthumbs (https://invent.kde.org/multimedia/ffmpegthumbs), and
I have managed to get some simple code working in Dolphin.

The problem is that some part of the system (some kind of KDE service
cache?) seems to be caching my thumbnailer's shared library because
when I change its code and recompile, the new changes don't seem to
come into effect right away. I don't know what triggers it to
eventually load the new version - it seems to just magically happen
after a few minutes. Even if I restart Dolphin, disable and re-enable
the thumbnailer in Dolphin, or run `kbuildsycoca5 --noincremental` -
it doesn't seem to change anything. It's borderline impossible to
develop when I can never be sure if it's running the old or the new
version.

My current code isn't online anywhere yet, but it's still mostly
identical to kffmpegthumbnailer if that helps. I simply symlinked the
.so-file in /usr/lib/x86_64-linux-gnu/qt5/plugins (so it should always
see the newest version), the .desktop-file for the service in
/usr/share/kservices5 and the .kcfg-file in /usr/share/config.kcfg.

Can I maybe force KDE to reload the new library, or something similar?

Regards,

David Lerch


More information about the kde-devel mailing list