configure not finding qt-mt

Hanspeter Niederstrasser nieder at OCF.Berkeley.EDU
Wed Sep 1 04:49:49 CEST 2004

A package I'm compiling is not finding the Qt libraries during 
compilation.  The error given is below:

checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not 
found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!

I have Qt 3.2.3 X11 by manually installing the tarball.  profile.d is 
being sourced and QTDIR is set to /opt/qt/3.2, as well as having 
/opt/qt/3.2/bin in my PATH.  Linguist, designer, and assistant all work 
fine, so the Qt installation seems OK.

I have LDFLAGS set to "-L/opt/qt/3.2/lib" and CFLAGS is 
"-I/opt/qt/3.2/include".  My configure line is "./configure 
--with-qt-dir=/opt/qt/3.2 --with-qt-includes=/opt/qt/3.2/include 
--with-qt-libraries=/opt/qt/3.2/lib" using the options suggested by 
"./configure --help" (I've also tried without the Qt options set).  And 
looking through config.log I could tell that the Qt libraries and includes 
were not found, but I couldn't figure out what specifically it was looking 
for that failed.

Might this be something as simple as expecting a differently named 
library?  I have lib/libqt-mt.dll as a link to bin/cygqt-mt-3.dll and I 
tried making my own links named qt-mt and libqt-mt but they didn't work

Any pointers or help would be appreciated.


More information about the kde-cygwin mailing list