DCOPserver, didn't read the expected 59 bytes - continual failure

dongetzin dongetzin at povpromotions.com
Fri Feb 27 04:59:18 CET 2004

Seems to work!   I changed HOME temporarily.  I remounted to bin mode.  ...
And it works.

I'll change startx next.  (BTW, I wish the kde group would call their startx
something else, like startk, so I have a choice on startup!!)

Looks like it's the fact that it chokes if HOME points to a directory path
with spaces in it.

Thanks again, Ralf

-----Original Message-----
From: Ralf Habacker [mailto:ralf.habacker at freenet.de] 
Sent: Thursday, February 26, 2004 3:49 AM

Take a look into /opt/kde3/bin/startx. You will find a line : 

  if ! test -f "$HOME/.kde_mountchecked"; then

which is based on the HOME directory. To set your HOME directory to another 
path only for the kde session, run 

  export HOME=/opt/kde3/home
  startx ... & 


On Wednesday 25 February 2004 19:42, don wrote:
> I've tried everything in the lists.  Even uninstalled and reinstalled 
> 4 times so far.
> I changed my mount points to:
> 	d:\Programs\cygwin\opt\kde3 on /opt/kde3 type system (binmode)
> 	d:\Programs\cygwin\bin on /usr/bin type system (binmode)
> 	d:\Programs\cygwin\lib on /usr/lib type system (binmode)
> 	d:\Programs\cygwin on / type system (binmode)
> 	c: on /cygdrive/c type user (textmode,noumount)
> 	d: on /cygdrive/d type user (textmode,noumount)
> Still get a halt and subsequent failure:
> 	First failure (lines 7-8) is when it finds spaces in the 
> .kde_mountchecked directory name. Second failue (line 78) rm -rf 
> /tmp/ksocket-dgetzin /opt/kde3/home/tmp-dgetzin1p4 \n rm: cannot open 
> current directory: No such file or directory Third failure (last 
> lines) "Error reading from /cygdrive/c/Documents and 
> Settings/dgetzin/.DCOPserver_dgetzin1p4__0,
> didn't read the expected 59 bytes"
> Is this perhaps all related to directory names with spaces in them? 
> How do I change where cygwin writes ".kde_mountchecked" and the 
> ".DCOPserver_dgetzin1p4__0" files ? I would like to test a path with 
> no spaces.

More information about the kde-cygwin mailing list