I used QT3-win32 libqt.dll in QT3!?

Alvyn Liang sacch.liang at msa.hinet.net
Thu Apr 8 02:48:24 CEST 2004

I don't know if this is something normal; however, I am a little ashamed of myself doing this.
Since I got only one response from Ralf tonight. I was so disappointed.

I always wish to produce some program using cross-platform compiler and kits. Mainly molecular calculation programs.
So I studied OpenGL, C++. I also bought couple of books about OpenGL, C++ and GCC.
Reminding from the first night I started to install lengthy QT and KDE in XP, I was really a newbie in this kind of thing, although
I compiled several other libraries before. (So far, I am of course still a newbie.)
I got a information from my friend about QT in the early morning and started to download different version of QT and tried to work
them out in cygwin. Then I found this site http://kde-cygwin.sourceforge.net. I was very excited and started to check if I can do
this and that.

In the beginning, I looked over the configuration process, found out the configuration said there was no OpenGL support. I was so
sad and tried many other ways to work it out. Finally I don't know why it showed the OpenGL support is yes. This is my first version
of successfully compiled QT, let's say it is QT-junior.
After I installed QT in cygwin I noticed there are some different softwares on this site, and one of it catch my attention was KDE.
KDE is a desktop I used several years before when I tried to build a website in my small laptop. This kind of stupid memory of
course reminds me what was it (KDE). I started to look at the information of KDE.

Then, of course, I tried to install KDE. This took me about four days to complete it, because the cygwin.exe download the files in a
turtle speed. And in the end of the session it always told me download incomplete. I was sooooo stupid to clean up all the contents
in my download folder, and *re*download them again and again. >_<

Finally in the fourth day, I resolved many problems, but I still cannot compile any QT program in this new cygwin. The QT inside the
new package (QT-senior) seems not working very well on my machine. I understand that might because I am too stupid to make it work.
Just before I post this article, I found out a way to make it compile. That is, set QTDIR to the junior's path before I compiled

The reason I did so is because QT3 provides cygqt-mt-3.dll, it seems not working under win32 system. (If I said anything wrong
please correct me) mt stands for multi-thread, I found some information on other website talking about they were using another
platform and just happened the problem the same condition with me, but reversely, in their case they should replace cygqt-3.dll by

It certainly compiled all the tutorial programs and the programs can be excuted in KDE. or, startx.
The full procedure of changing the contents are quite complicated. Even I cannot clearly tell how I did it. I remember I copied all
the contents of the mkspecs folder QT-junior into QT-senior. And that is important process for me to pass the qmake.

More information about the kde-cygwin mailing list