What happened to my KDE?

Jelks Cabaniss jelks at jelks.nu
Thu Apr 1 23:28:47 CEST 2004

I've been running Cygwin (with X) for several years now on WinXP.  A couple
of months ago or so I installed KDE3 and it worked great.

For some reason (can't exactly remember why) I switched back to
mirrors.kernel.org.  I did several non-KDE upgrades, and everything --
including KDE -- still worked great.

Then a few days ago, I ran the Cygwin installer to see if there was anything
new.  Wow -- a *bunch* of X-related stuff!  I installed it all.  

And KDE no longer worked.  :(

So I switched back to using the Cygwin URL and saw there a couple of
KDE-related packages flagged for upgrading, so I did so.  Still KDE did't

So I uninstalled *everything* KDE-related with the Cygwin installer.  Just
to make sure I then even removed the paths manually mentioned on the Cygwin
KDE3 installation page.  I then reinstalled and ran 'rebaseall -v'.  

It *still* does NOT work (though plain Xwindows with TWM -- startxwin.bat --
works fine).  

Running 'startx -rootless &' (which is what I had been running earlier)
complained about a missing ~/.Xauthority, so I 'touch'ed one.  Still no go;
it gives me this error message:

	xinit:  No such file or directory (errno 2):  
	no program named "/usr/X11R6/bin/xterm" 
	in PATH

Well, yeah -- xterm.exe is in /usr/bin.

So what can I do to fix this?

BTW, running 'startx &' from a bash console now gives me a single GUI xterm
-- no KDE desktop like before!

Also (and perhaps unrelated), every time I run the Cygwin installer using
the KDE-Cygwin URL, it tells me there's a KDE network package upgrade.  So I
continue through, but evidently it doesn't take because if I re-run the
installer, there it is again.  And again and again and again.

Any help would be greatly appreciated.



More information about the kde-cygwin mailing list