Help needed kde-devel 3.1.1

Jeff Owen jefflynne at
Sat Jul 26 11:01:48 CEST 2003

Thanks Ralf, I have started working my way through this process and have
built qt3.  I am now completely stuck with glib-2.2.1.  I get this error:

/bin/bash ../libtool --mode=link gcc-2 -g -O2 -Wall -o -rpath /opt/gtk/lib -version-info
200:1:200 -export-dynamic -no-undefined gboxed.lo gclosure.lo genums.lo
gobject.lo gparam.lo gparamspecs.lo gsignal.lo gsourceclosure.lo gtype.lo
gtypemodule.lo gtypeplugin.lo gvalue.lo gvaluearray.lo gvaluetransform.lo
gvaluetypes.lo ../glib/ -lintl
*** Warning: This system can not link to static lib archive
*** I have the capability to make that library automatically link in when
*** you link to this library. But I can only do this if you have a
*** shared version of the library, which you do not appear to have.

I have tried searching the web and found references to this problem, which
seems to be a known problem with cygwin/libtool. I think you have also made
reference to it as well.  However, I haven't found the patch and I can't get
round this,

Sorry to be a pest

----- Original Message ----- 
From: Ralf Habacker
To: For developers interested in porting KDE to Windows using Cygwin
Sent: Friday, July 25, 2003 12:03 PM
Subject: RE: Help needed kde-devel 3.1.1

Hi Jeff,

you should read and

If that does not help, ask agin.

-----Original Message-----
From: at
[ at]On Behalf
Of Jeff Owen
Sent: Wednesday, July 23, 2003 9:57 PM
To: kde-cygwin at
Subject: Help needed kde-devel 3.1.1

I hope this is posted to the right place.  I need some help in installing
"setup-kde-3.1.1-b1-devel.exe". Also, some advice as to what KDE
applications would be expected to compile would be helpful.

I have installed a cygwin, setup-kde-3.1.1-b1.exe and
setup-kde-3.1.1-b1-u1.exe.  KDE runs fine, but quite slowly and I am very
Boldened, I thought I would try to compile a KDE application and I choose

When I run configure it complains that it can't find qt-mt when it gets to
the bit where it checks for qt.
(configure:21734: error: Qt (>= Qt 3.1 (20021021)) (library qt-mt) not
found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!)

Config log shows the following to have failed:
configure:21691: rm -rf SunWS_cache; g++ -o
conftest.exe -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -W
pointer-arith -Wmissing-prototypes -Wwrite-strings -O2 -fno-exceptions -fno-
check-new -I/opt/kde3/include -I/usr/X11R6/include -DQT_THREAD_SUPPORT -L/op
t/kde3/lib -L/usr/X11R6/lib -lqt-mt -lpng -lz -lm -ljpeg -lXext -lX11 -lSM -lICE -lpthread
cannot find -lqt-mt
collect2: ld returned 1 exit status
configure:21694: $? = 1

The first question I have is, where do you install
"setup-kde-3.1.1-b1-devel.exe". Should it go over /opt/kde3 or in a separate
location, I have tried both.  By default it seems to want to put it in
\program files\KDE3.1, if you try to put it in /opt/kde3 it complains about
writing to an existing directory. However, the file lib\libqt-mt.dll is a
.lnk file to ../bin/cygqt-mt-3.dll, which seems to imply that they should
all go into the same place.  I notice the FAQ has a script to fix up the
links and I have tried this as well all to no avail.

I am using a command like:
./configure --with-qt-dir=/opt/kde3

Thanks in advance


kde-cygwin mailing list
kde-cygwin at

More information about the kde-cygwin mailing list