QT3 Win32 compiling problems

Jan-Steinke at gmx.de Jan-Steinke at gmx.de
Mon Jul 21 22:34:55 CEST 2003

@Richard Lärkäng & Ralf Habacker:

> Any way you could do some more research on it?

Yes,I tried the command (from Ralf Habacker):

> sh -x ./configure -platform
> cygwin-g++ -fast -plugin-imgfmt-mng -thread -no-stl -system-zlib -qt-gif -syst
> em-libpng -system-libjpeg -qt-libmng -no-g++-exceptions -no-xft -no-xkb -disable
> -opengl

(I used cygwin-g++, not cygwin-g++-2 (like you wrote me). g++-2 didn't work)

and it first stops working(like I described)at the following point:

+ cd /home/Jan/qt-3/qmake.exe
make -f Makefile qmake.exe
make[1]: Entering directory `/home/Jan/qt-3/qmake`
make[1]: `qmake.exe` is up to date
make[1]: Leaving directory `/home/Jan/qt-3/qmake`
+ rm -f /home/Jan/qt-3/include/qmake/qconfig.h`
+ rm -f /home/Jan/qt-3/include/qmake/qmodules.h
+ rmdir /home/Jan/qt-3/include/qmake
+ [yes = yes ]
+ /home/Jan/qt-3/config.tests/x11/notype.test /home/Jan/qt-3/mkspecs/cygwin-g++
no /home/Jan/qt-3 /home/Jan/qt-3
+ [ no = yes ]
+ [cygwin-g++ = hpux-acc -a no != no ]
+ [no = auto ]
+ [auto = auto]
+ /home/Jan/qt-3/config.tests/unix/largefile.test /home/Jan/qt-3/mkspecs/cygwin-
g++ no /home/Jan/qt-3 /home/qt-3

Then I closed qmake in the taskmanager and it continues until this:

+ /bin/sh -c /home/Jan/qt-3/bin/qmake -spec /home/Jan/qt-3/mkspecs/cygwin-g++
-o /home/Jan/qt-3/./src/moc /home/Jan/qt-3/.src/moc/moc.pro

now I've got again the same problem like before. qmake.exe uses all my Computer 
Resources & nothing more happens.
I hope you can give me some help now.

my original message was:

> > Hi there,
> > I downloaded the QT3 Win32 sources and tried to compile them. when I run
> > $. .config.cygwin
> > nothing happens and in my WinXP(prof) TaskManager I can see, that qmake
> uses 90-
> > 98 % of my Computer resources. Then I waited for half an hour, but
> nothing, except my
> > CPU (AMD Athlon 1200) gets hot. So, whats wrong with it?
> > Thanks for help,
> > Jan

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.kde.org/pipermail/kde-cygwin/attachments/20030721/19756aa9/attachment.htm

More information about the kde-cygwin mailing list