<div dir="ltr"><br>‚ÄčThe binary is called kpackagetool. Given the complications we've had with frameworks co-installability does it make sense to call it kpackagetool5?<div><br></div><div>The class name in kpackagetool/kpackagetool.cpp should probably be renamed</div><div><br></div><div>Documentation at the top of PackageLoader should avoid saying Plasma quite so much</div><div><br></div><div>commented line at 773 of package.cpp looks concerning. I think it is just dead code.</div><div><br></div><div>Installation command of plasmoids.knsrc are wrong (in fact they're wrong for current plasmapkg)<br></div><div>Should kpackage even be providing this file? I think it should be with the plasmoid definition.<br></div><div><br></div><div>IMHO PackageJob probably shouldn't set a parent to the packagestructure.</div><div>Otherwise if you create a PackageStructure on the stack then call install/uninstall it will delete the job before it's finished.<br></div><div><br></div><div>¬†There's a Qt5 TODO on PackageJobThread::removeFolder</div></div>