announcement: plymouth-kcm in kdereview

Marco Martin notmart at
Thu Jan 5 15:03:21 GMT 2017

On Thursday 05 January 2017 12:30:38 Jonathan Riddell wrote:
> It should rather follow Plasma practice and set these in the top cmake file
> set(PROJECT_VERSION "5.8.90")

would this number be automagically updated one this gets into workspace?

> same for const char version[] = "1.0"; src/kplymouththemeinstaller.cpp
> The kcm is LGPL while the helper executables are GPL, probably simpler just
> to make it all GPL.
> The copyright headers should follow current best practice text listed at
> There's no docs, I don't know if anyone cares about these for kcms any
> more, probably not.  Seems a general System Settings issue, the Help
> button is shown but does nothing when I click it even for
> e.g. kcmshell5 colors. This works again when I install khelpcenter but
> it should have sensible fallback like apps do.  Except the apps launch
> a web page which doesn't exist.  Is it time to just give up on docs
> and accept they're not actually that important?

i get the button disabled here, which i think is fine.

> I get quite a few warnings/errors when running kcmshell5 plymouth:
>  org.kde.kcoreaddons: Error loading plugin "kcm_plymouth" "The shared
> library was not found." Plugin search paths are
> ("/usr/lib/x86_64-linux-gnu/qt5/plugins", "/usr/bin") The environment
> variable QT_PLUGIN_PATH might be not correctly set

this warning doesn't make sense and i can't reproduce (it should not work at 
all then, but it's working) sure you don't have a spurious old installation 
left somewhere?

> kf5.kcoreaddons.desktopparser: Could not locate service type file
> kservicetypes5/kpackage-genericqml.desktop, tried ("/home/jr/.local/share",
> "/usr/share/usr/share/xsessions/plasma", "/usr/local/share", "/usr/share",
> "/var/lib/snapd/desktop")

this is probably a kcpackage issue: that type is built in kpackage and doesn't 
have a plugin. i don't know where the warning comes from tough

> file:///usr/lib/x86_64-linux-gnu/qt5/qml/QtQuick/Controls/Button.qml:100:
> TypeError: Cannot read property of null

qqc1 upstream bug

> When I run kcmshell5 plymouth  and use the corners to resize the window
> larger and smaller after a short while it freezes and gives output of
> file:///usr/share/kpackage/kcms/kcm_plymouth/contents/ui/main.qml:48:13:
> QML GridView: Binding loop detected for property "cellWidth"

should be fixed now

> The top text says "Plymouth splash screen". It should be in title case.
> There's no preview pic for my pre-installed splash screens.  Probably none
> is available but there must be some way to make one available for breeze
> themes at least?

yes, the breeze splash screen can get a "preview.png" file in it, it would get 
picked up

> When I click Defaults nothing much happens, what is this button supposed to
> do?

eh, in this case it doesn't really mean anything, but i can't remove it :/

> When I click Reset it resets back to the current setting.  When I then go on
> to select another theme the Reset button does not become enabled again and
> output says
> file:///usr/share/kpackage/kcms/kcm_plymouth/contents/ui/main.qml:136:
> ReferenceError: resetCheckbox is not defined


> No Product in bugzilla
> when one is added you'll need to add it to releaseme
> plasma/plasma-add-bugzilla-versions

should be a component in plasmashell being in workspace?

> No Product in Phabricator
> The terminology changes between 'System Splash', 'Plymouth Splash Screen',
> 'global splash screen' and '[Get New] Splash Screens'.  Better to pick one
> I think, I like 'Boot Splash'.
naming should be a tad more consitent now

Marco Martin

More information about the kde-core-devel mailing list