announcement: Kwave is in kdereview / _(...) macro
Thomas.Eschenbacher at gmx.de
Tue Oct 18 05:55:43 BST 2016
On 17.10.2016 23:30, Jan Kundrát wrote:
> On úterý 11. října 2016 21:41:09 CEST, Thomas Eschenbacher wrote:
>> the _(...) macro has nothing to do with i18n
> Isn't that a bit confusing? Underscore is used by gettext to mean the
> *opposite* from what Kwave uses it for.
really? I have never seen that...
> It is also a reserved identifier
> in C++. Inventing non-standard idioms with non-obvious semantics just to
> save one from typing QLatin1String or QStringLiteral doesn't seem like a
> good idea.
Spilling the source with hundreds of QLatin1String(...) wrappers is even
worse, that really sucks, as it makes the code really ugly and unreadable.
I prefer using a macro for that purpose, because I have the impression
that this wrapping is some kind of "fashion" which might probably change
over time, maybe in the next Qt version one has to use a different
wrapper class, and I don't want to waste time in changing 850 places in
the code, instead I would like to have _one_ central place to adapt it.
OK, so if you could suggest a better alternative, I could change this!
Something that is short, like 1..3 characters, and is not already a reserved
token for whatever. Any ideas?
More information about the kde-core-devel