kdelibs and Qt version dependency

Albert Astals Cid aacid at kde.org
Thu Jun 7 17:57:42 BST 2012

El Dijous, 7 de juny de 2012, a les 09:27:22, Aaron J. Seigo va escriure:
> On Wednesday, June 6, 2012 20:32:49 Albert Astals Cid wrote:
> > Someone from plasma?
> summary: no hard requirement to jump to Qt 4.8 from plasma at this time ...
> Qt 4.8 brings a number of speed improvements and general goodness which
> certainly helps the various Plasma workspaces, but i do not believe we have
> any hard requirements on it at this time ... so i'd love to see people using
> Qt 4.8, but we can keep a minimum 4.8 requirement for the time being.

You meant "but we can keep a minimum 4.7 requirement for the time being."?

Asking because otherwise i don't understand the "but" in the sentence


> my only concern is that our team works with Qt 4.8 right now, most of our
> users will likely get Qt 4.8 with SC 4.9 packages and so our code will be
> well tested with Qt 4.8 and Qt 4.7 will not be as well tested. i don't
> think there is much we can do about that though, unless a magic QA fairy
> passes by dropping testers. :)

More information about the kde-core-devel mailing list