Review Request: Make mouse cursor size configurable

Christoph Feck christoph at maxiom.de
Tue Jul 12 09:56:01 BST 2011


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://git.reviewboard.kde.org/r/101701/#review4633
-----------------------------------------------------------



kcontrol/input/xcursor/cursortheme.h
<http://git.reviewboard.kde.org/r/101701/#comment4057>

    If you change this line, remove the trailing space.



kcontrol/input/xcursor/previewwidget.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4058>

    "const" for an "int" argument is not required ("int" is passed by value).



kcontrol/input/xcursor/themepage.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4059>

    I think a better name is "defaultSize".



kcontrol/input/xcursor/themepage.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4060>

    Inconsistent placement of { and } around "if".
    
    Please use kdelibs style for new code.



kcontrol/input/xcursor/themepage.ui
<http://git.reviewboard.kde.org/r/101701/#comment4065>

    sizePolicyComboBox, there is no Police here ;)



kcontrol/input/xcursor/xcursortheme.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4064>

    pleaseCamelCaseLongerNames



kcontrol/input/xcursor/xcursortheme.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4063>

    Do you mean the sizes are always > 0, or do you mean the number of entries in the list is > 0 ("never empty")?
    
    Do we need some logic to prevent it saying "Available sizes:" when only one size is available? But I am not sure if i18n can handle that.



kcontrol/input/xcursor/xcursortheme.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4061>

    "owned"



kcontrol/input/xcursor/xcursortheme.cpp
<http://git.reviewboard.kde.org/r/101701/#comment4062>

    Clever! :) I love it when stuff adapts to DPI.


- Christoph


On June 20, 2011, 10:04 a.m., Lukas Sommer wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://git.reviewboard.kde.org/r/101701/
> -----------------------------------------------------------
> 
> (Updated June 20, 2011, 10:04 a.m.)
> 
> 
> Review request for KDE Base Apps, KDE Runtime, kdelibs, and Christoph Feck.
> 
> 
> Summary
> -------
> 
> X11 mouse cursor themes can contain cursors in multiple sizes, making them pseudo-scalable.
> 
> It is yet possible in KDE to configure manually the mouse cursor size (editing kcminput.rc). However, the GUI of the corresponding KControl module didn't provide support to change this. This patch add support for changing the mouse cursor size to the GUI.
> 
> This are mostly GUI related changes. The underlying data structure XCursorTheme did yet provide support for choosing different sizes and only needed some adjustments.
> 
> 
> This addresses bug 90444.
>     http://bugs.kde.org/show_bug.cgi?id=90444
> 
> 
> Diffs
> -----
> 
>   kcontrol/input/xcursor/xcursortheme.cpp a987487 
>   kcontrol/input/xcursor/themepage.ui 2e38054 
>   kcontrol/input/xcursor/xcursortheme.h b474086 
>   kcontrol/input/xcursor/themepage.h 902148f 
>   kcontrol/input/xcursor/themepage.cpp 24b9efe 
>   kcontrol/input/xcursor/previewwidget.h f4d2c4e 
>   kcontrol/input/xcursor/previewwidget.cpp 3c264fc 
>   kcontrol/input/xcursor/cursortheme.h 8f7834b 
>   kcontrol/input/xcursor/legacytheme.h 23c9d5f 
> 
> Diff: http://git.reviewboard.kde.org/r/101701/diff
> 
> 
> Testing
> -------
> 
> Tested locally. Works fine for me. Also when using non-standard font DPI values.
> 
> 
> Screenshots
> -----------
> 
> 
>   http://git.reviewboard.kde.org/r/101701/s/188/
> 
>   http://git.reviewboard.kde.org/r/101701/s/189/
> 
> 
> Thanks,
> 
> Lukas
> 
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20110712/44ea2eec/attachment.htm>


More information about the kde-core-devel mailing list