[ANNOUNCE] CMake 2.6.4 will be required for trunk/ May 1st

Alexander Neundorf neundorf at kde.org
Thu Apr 15 20:47:09 BST 2010


On Thursday 15 April 2010, Matthew Woehlke wrote:
> Ralf Habacker wrote:
> > Just one question: Is it with [2.6.4] be possible to use the following
> >
> > if(expression)
> > else()
> > endif()
> >
> > in KDE related cmake scripts ? It would be help writing if statements
> > less error prone.
>
>  From the official FAQ┬╣: "As of CMake 2.6.0 the ELSE() and ENDIF()
> constructs can be empty." So unless you are talking about public scripts
> (e.g. FindKDE4) and those are supposed to still work on 2.4.x, then this

Everything shipped with kdelibs >= 4.2 or depending on kdelibs >= 4.2 requires 
at least CMake 2.6.2, so basically for everything in KDE trunk/ this should 
be ok.

Alex
_______________________________________________
Kde-buildsystem mailing list
Kde-buildsystem at kde.org
https://mail.kde.org/mailman/listinfo/kde-buildsystem


More information about the kde-core-devel mailing list