Merging KAuth into KDELibs

Ingo Klöcker kloecker at
Sat Sep 12 13:52:19 BST 2009

On Monday 07 September 2009, Oswald Buddenhagen wrote:
> On Mon, Sep 07, 2009 at 01:38:43PM -0600, Aaron J. Seigo wrote:
> > On September 5, 2009, Oswald Buddenhagen wrote:
> > > dunno. you dismissed KAuthorized as "unmaintained" without
> > > further comment. if that isn't a reason for concern, then i don't
> > > know what is.
> >
> > it's fairly accurate to say that the kiosk framework is quite
> > nearly unmaintained.
> that's certainly true, but not the point.
> > [explanation KAuth vs. KAuthorized]
> i suppose that's good enough. :)
> but it confirms that KAuth is a bad name.

I agree with Ossi. If I would not have followed this discussion I'd 
assume that one is the successor of the other.

KAuth is a bad name in itself because it's an abbreviation of some word 
starting with "auth", like "author". There is no precedent for this in 
the list of namespaces in kdelibs/kdecore.

KAuthorized is a bad name in itself because "authorized" is an 
adjective. IMO we should use nouns for namespaces and class names, e.g. 
KAuthorization or KAuthority (or something else, see below).

BTW, the KAuth namespace lacks a brief description in the API docs. And 
the brief description of the KAuthorized namespace is rather 
useless: "Extracted from kapplication (3.x).". (See

On Monday 07 September 2009, Aaron J. Seigo wrote:
> > KAuthorized is a nice, simple interface for an
> > app to ask "should this app show and allow this kind of action?"

KAllowance or KPermission? Yes, I know that this cannot be changed 
before KDE 5.

> > and 
> > KAuth is a nice interface to getting that information from the
> > system.

IMO it should be renamed to KAuthorization. The Introduction of this 
namespace starts with "The KDE Authorization API [...]" so this name 
seems to fit best.

Having two namespaces KAuthorization and KAuthorized is surely not more 
confusing than having two namespaces KAuth and KAuthorized.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list