KNotificationItem class name is confusing

Marco Martin notmart at
Thu Oct 29 09:25:09 GMT 2009

On Wednesday 28 October 2009, Aurélien Gâteau wrote:
> Marco Martin a écrit :
> > dunno if i do.. but anyways, to summarize:
> > -the thing -does- want to be part of the notification system
> As I replied to Aaron, do you consider that a KNotificationItem is an
> element inside a KNotification? if it's not then the name is not
> appropriate IMO.
> > -other names doen't seem -much- better
> >
> > -honestly i don't really want to embark in a mission of unbreaking the
> > whole trunk after renaming it, unless there is a -really- better name
> As the starter of this discussion I would like to offer my help should
> you decide to rename the class. I believe it can be done without
> breaking trunk. Here is how I would do it:
> 1. Rename the DBus object
> 2. Rename knotificationitem.{h,cpp} to newclassname.{h,cpp} and rename
> the class in it
> 3. Create knotificationitem.h with the following content:
>    #include <newclassname.h>
>    typedef NewClassName KNotificationItem;
> At this point, the class is renamed, but trunk should still build.
> 4. Adjust existing code to use NewClassName.
> 5. When all code has been adjusted, remove knotificationitem.h
> Aurélien
i do agree with Aaron that KStatusNotifier seems the nicer one because it -is- 
related to notifications and yes knotificationitem can suggest that is 
actually one of the notifications, so it can be improved.

that sounds like a good migration strategy, if KStatusNotifier is accepted 
enough by people and if there is someone willing to help with the process, we 
can do it even later today

Marco Martin

More information about the kde-core-devel mailing list