KNotificationItem class name is confusing

David Jarvie djarvie at
Wed Oct 28 09:33:39 GMT 2009

On Wed, October 28, 2009 9:17 am, Sebastian Trüg wrote:
> I agree that the name is not great. Remind me why we are not using
> somethign
> like "KSystrayItem"? Sure, systray is a weird word but everyone knows what
> it is...

> On Wednesday 28 October 2009 09:57:08 Aurélien Gâteau wrote:
>> - KNotificationAreaItem: This is consistent with the fact that these are
>> items from the "Notification Area". Still it contains the word
>> Notification, which I do not believe should be there.
>> - StatusAreaItem: I thought about this one when I read a post about the
>> work done by Fedora people on systray icons [1]. In this post they call
>> the icons "status icons".
>> What do you think? Is it too late? Am I just a painful nit-picker? Do
>> you have better ideas?

I agree that it's not obvious what this class is about, and that the name
is misleading. Either of your suggestions would be an improvement, or
ideally something like what Sebastian suggests. Let's change it for 4.4.

David Jarvie.
KDE developer.
KAlarm author & maintainer.

More information about the kde-core-devel mailing list