Review Request: Introduce two new KCrash methods: void setLaunchDrKonqi(bool) and bool launchDrKonqi().

Thiago Macieira thiago at
Sun Oct 25 18:45:02 GMT 2009

Em Domingo 25. Outubro 2009, às 17.33.09, George Kiagiadakis escreveu:
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> -----------------------------------------------------------
> Review request for kdelibs.
> Summary
> -------
> This patch introduces two new methods in the KCrash namespace: void
>  setLaunchDrKonqi(bool) and bool launchDrKonqi(). The reason for

The name "launchDrKonqi" is a bad one. "Launch" is a verb in the imperative, 
so "launchDrKonqi" doesn't look like a setter, but an action.

I recommend using "launchesDrKonqi" instead.

Also, for boolean properties, prefixing the getter with "is" is recommended, 
but then you need an adjective as the core of the property name (as in 
"isDrKonqiLaunchEnabled"). If you can't come up with a good name, don't use 
"is", it's not a problem.

Thiago Macieira - thiago (AT) - thiago (AT)
  Senior Product Manager - Nokia, Qt Development Frameworks
      PGP/GPG: 0x6EF45358; fingerprint:
      E067 918B B660 DBD1 105C  966C 33F5 F005 6EF4 5358
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 190 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list