patches for custom styleelements, kcapacitybar

Maksim Orlovich mo85 at
Thu Nov 13 18:20:28 GMT 2008

> Am Friday 24 October 2008 schrieb Maksim Orlovich:
>> I don't think the ID lookup methods should be named styleHint, etc.,
>> since
>> [...]
>> QPalette for a particularly bad instance). May be queryStyleHintId or
>> such? (I kind of suck at naming).
> I chose customStyleHint() etc. - has the advance of a coherent beginning
> and i
> (personally) don't like "query" or "get" functions too much (unless you
> query
> a dbase or get files via a network, of course)
> A second change is QHash as replacement for QMap, as in the current
> implementation, we'll most probably (hopefully ;-) cross the 10 elements
> mark
> pretty soon.
> I also went through the comments (fixing at least some typos...) and API
> docs -
> clarifying the relevance of the "CE_" etc. token and commented on abuse of
> custom elements (i'd prefer too keep an example for the app as imho
> examples
> are easier to understand and systematize than generic explanations - but
> obviously i don't mind if you remove it)

I didn't respond to this, did I? Anyway, this looks great! Feel free to go
ahead and commit. Thank you for bearing w/my slow-derriere ultra-picky

More information about the kde-core-devel mailing list