KDE 4.1 login fails for new user

David Jarvie djarvie at kde.org
Sat Jul 12 15:26:31 BST 2008

I removed the ~/.kde directory and tried to log in using KDE 4.1 (SVN 
yesterday). It showed the error message "Could not start kstartupconfig4. 
Check your installation." before aborting the login. The error code being 
returned by kstartupconfig4 was 3. Repeating the login attempt resulted in 
the same error.

By my reading of the code, kdostartupconfig.cpp calls

    KStandardDirs::locateLocal( "config", "startupconfigkeys" );

and then tries to open the resultant file name in read-only mode - hence the 
error. When you start with an empty ~/.kde, that file won't exist, so AFAICS 
kstartupconfig4 will inevitably return the error code 3. (The directory 
~/.kde/share/config was created with correct user permissions, presumably by 
that call, so there's no problem with write access.)

David Jarvie.
KAlarm author and maintainer.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20080712/11929249/attachment.sig>

More information about the kde-core-devel mailing list