KDE TRUNK & Qt-4.4.x (pre-release in qt-copy)

Andreas Pakulat apaku at gmx.de
Sun Feb 17 19:41:47 GMT 2008

On 17.02.08 11:33:35, James Richard Tyrer wrote:
> I understand that KDE TRUNK now requires Qt >= 4.4.0 although I didn't 
> see an actual announcement to that effect on the list.

The switch to Qt4.4 on trunk/qt-copy was announced last thursday or
friday and it was also announced that the dependecy wasn't going to be
done for a few days so people have some time to update their builds.

> However, I find that:
> 	The CMake scripts do not check for this.
> 	The README files do not say that 4.4 is required and where to
> 	get it.
> This has resulted in totally unnecessary bug reports (and duplicates) 
> and will probably result in more.

No, its good now.

> This should be fixed ASAP.  Actually, it should have been fixed before 
> any code dependent on Qt-4.4.x was committed.
> This is unprofessional quality management.

Looks like somebody made a mistake, good you never make mistakes.

BTW: the kde-devel IRC channel already mentions the dependecy since 24


If you sow your wild oats, hope for a crop failure.
>> Visit http://mail.kde.org/mailman/listinfo/kde-devel#unsub to unsubscribe <<

More information about the kde-core-devel mailing list