starting a kde4 app that's not installed in the same place as the rest of kde4?

Boudewijn Rempt boud at
Sun Feb 17 12:19:32 GMT 2008

On Sunday 17 February 2008, Thiago Macieira wrote:

> No.
> You have to make that apply to all KDE 4 applications and those only.

Then I'm still stumped :-(. I've checked that in the initial situation kded4 
and knotify4 are not running; so nothing from kde4 is running as far as I can 

When I run a locally installed koffice app for the first time, I get:

krita(4926)/koffice (lib komain) 
KoDocument::readNativeService: "kritapart.desktop"  found.
krita(4926)/koffice (lib komain) KoDocumentEntry::createDoc: "Library not 
kdeinit4: preparing to launch /usr/lib64/kde4/libexec/klauncher
kdeinit4: preparing to launch /usr/bin/kded4
kdeinit4: preparing to launch /usr/bin/kbuildsycoca4
kbuildsycoca4 running...
kdeinit4: preparing to launch /usr/lib64/kde4/libexec/kconf_update
kdeinit4: preparing to launch /usr/bin/knotify4
krita(4926): Couldn't start knotify from knotify4.desktop:  "KDEInit could not 
launch '/usr/bin/knotify4'."

I've even tried adding the pluginpath hard-coded using 
QApplication::addLibraryPath. Checking the librarypaths gives: 

("/src/inst/lib/kde4", "/src/inst/lib", "/usr/lib64/kde4/plugins", "/usr/lib/kde4/plugins", "/usr/lib64/qt4/plugins", "/src/inst/bin")

Weirdly enough, despite the last line, knotify4 does run after this call and 
subsequent attempts to start Krita only give:

krita(4950)/koffice (lib komain) 
KoDocument::readNativeService: "kritapart.desktop"  found.
krita(4950)/koffice (lib komain) KoDocumentEntry::createDoc: "Library not 

Boudewijn Rempt

More information about the kde-core-devel mailing list