New class KWidgetBlendAnimation

Matthias Kretz kretz at
Mon Feb 4 10:42:53 GMT 2008

On Sunday 03 February 2008, Dmitry Suzdalev wrote:
> On Sunday 03 February 2008 17:19:05 Dominik Haumann wrote:
> > Maybe the word fade already implies that there is an animation and
> > KFadeWidget or KFadingWidget is enough?
> That sounds like it is some kind of widget rather than effect :)

Actually it is a widget, though probably that's an implementation detail and 
not really necessary to know. OTOH the widget part in the name is meant to 
show what is being faded: it is fading the UI changes of a widget.

> Maybe something like "KWidgetFadingEffect"?

Effect or Animation might be nice to have for discoverability (if we had a 
place where all our classes were listed).

I'll go with "KFadeWidgetEffect" now. Fade is the most important word in the 
name IMHO and goes first. Then it says what it is fading and Effect is added 
for clarity and discoverability.

You can still make better suggestions (but only with good reasons :-) ).

Thanks for all the thoughts...

Matthias Kretz (Germany)                            <><
MatthiasKretz at, kretz at,
Matthias.Kretz at
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
URL: <>

More information about the kde-core-devel mailing list