move QCoreApplication::addLibraryPath call from KApplication to KComponentData
faure at kde.org
Mon Dec 1 20:44:51 GMT 2008
On Wednesday 26 November 2008, Matthias Kretz wrote:
> On Wednesday 26 November 2008 01:09:03 David Faure wrote:
> > On Monday 24 November 2008, Matthias Kretz wrote:
> > > I still didn't get a "go ahead". Do you want me to change the atomic int
> > > to an int? I still think the patch should go in as is.
> > Personally I think this testAndSet stuff just makes this code unreadable,
> > especially if we all agree that it's pointless in code that will always be
> > single-threaded...
> > About code readability, this int should rather be an enum, too :-)
> New patch to KCD attached.
Looks good to me. Thanks.
David Faure, faure at kde.org, sponsored by Qt Software @ Nokia to work on KDE,
Konqueror (http://www.konqueror.org), and KOffice (http://www.koffice.org).
More information about the kde-core-devel