KTabBar -- double clicking on empty space

Constantin Berzan exit3219 at gmail.com
Mon Sep 10 16:46:42 BST 2007


On Sunday 09 September 2007 22:42, Thiago Macieira wrote:
> Andreas Hartmetz wrote:
> >++ for two signals and renaming the existing one to
> > tabDoubleClick[ed]().
>
> Feature freeze, source and binary compatibility. Let's stop renaming
> things.
>
> Yes, the name is wrong. Deprecate it and add the new one. Don't remove it
> until KDE 5.

Sounds scary :( How many more flaws like that have to live through an entire 
release cycle?...

Here's a preliminary patch. I'm listening in for suggestions / criticism. What 
I don't like is that KTabWidget uses:
mouseDoubleClick(QWidget *) and mouseDoubleClick()
mouseMiddleClick(QWidget *) and mouseMiddleClick()
contextMenu(QWidget *, QPoint &) and contextMenu(QPoint &)

perhaps we should settle for
mouseDoubleClick(int) and mouseDoubleClick()
mouseMiddleClick(int) and mouseMiddleClick()
contextMenu(int, QPoint &) and contextMenu(QPoint &)
in KTabBar as well?


I am confused by the code duplication. When a tab bar is used in a tab widget, 
why doesn't it occupy the entire upper part of it? Why do both KTabBar and 
KTabWidget have their own ways of determining if a point belongs to the empty 
tabbar area?





-- 
Read my book!
http://ascending.wordpress.com/2007/08/05/diaries-of-the-last-dreamer/
-------------- next part --------------
A non-text attachment was scrubbed...
Name: patch
Type: text/x-diff
Size: 3300 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20070910/0b9a7775/attachment.diff>


More information about the kde-core-devel mailing list