Why are methods like KIO::open_RenameDialog(), not called KIO::RenameDialog::open()?
rdale at foton.es
Thu May 31 15:16:21 BST 2007
On Thursday 31 May 2007, David Faure wrote:
> On Thursday 31 May 2007, Richard Dale wrote:
> > Well my point is that I can't see any reason why these methods are in a
> > namespace instead of in the classes that they could belong to as static
> > methods. If the original class name has to be encoded in the method name
> > like 'open_MyClassname', then it looks like some sort of workround to a
> > problem in C++, that an elegant naming scheme to me (imho underscores and
> > camel case don't mix). It is just as easy to type
> > KIO::RenameDialog::open() as KIO::open_RenameDialog().
> Yes this is old cruft (and *mostly* internal API anyway), feel free to make
> it KIO::RenameDialog::open().
OK good, and there were a few other similar methods in KIO:: like that that
I'd like to change too. I'll try and do it next Monday as I assume this will
More information about the kde-core-devel