Requiring CMake 2.4.5 ?
neundorf at kde.org
Mon Jan 29 16:48:14 GMT 2007
On Monday 29 January 2007 08:29, Adriaan de Groot wrote:
> On Sunday 28 January 2007 23:00, Alexander Neundorf wrote:
> > since september we are requiring CMake 2.4.3.
> > The current release is 2.4.6.
> > E.g. Kubuntu Edge Eft and I think SUSE 10.2 too ship with CMake 2.4.3.
> 2.4.3 has some important bugs for KDE3 compatibility, so we should want to
> push 2.4.4 or later anyway.
Actually that 2.4.3 has some problems with KDE 3 is IMO no reason to increase
the required version for KDE4.
Yes, requiring 2.4.5 or 2.4.6 for KDE4 would have the side effect that there
would be more installations which have a cmake without problems for KDE3, but
I see this really only as a side effect.
So if you need at least 2.4.5 (2.4.4 was somehow not so good), feel free to
put a "CMAKE_MINIMUM_REQUIRED(VERSION 2.4.5 FATAL_ERROR)" in the cmake files
of your KDE3 app.
Work: alexander.neundorf AT jenoptik.com - http://www.jenoptik-los.de
Home: neundorf AT kde.org - http://www.kde.org
alex AT neundorf.net - http://www.neundorf.net
More information about the kde-core-devel