[patch] knewstuff fix #105351
m.koller at surfeu.at
Fri Jan 5 20:29:10 GMT 2007
attached patch shall fix http://bugs.kde.org/show_bug.cgi?id=105351
I'd like to have your feedback if this is the correct approach, since inside
the BKO entry there is a proposed patch which modifies the returnvalue of
Entry::fullName(), but I'm not sure if this is a good idea that fullName()
returns something what is part of payload, namely the filename extension.
Therefore I implemented the extension handling in
A second thing I propose to change: if Entry::version() is not defined
(empty), then fullName() does not use it and only returns name(), which avoid
such bad names like "something--0"
OK to commit (in 3.5.5 and 4 of course) ?
Best regards/Schöne Grüße
Martin () ascii ribbon campaign - against html mail
/\ - against microsoft attachments
Computers and Internet gave you freedom.
TCPA would TAKE your FREEDOM! http://www.againsttcpa.com
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 1632 bytes
Desc: not available
More information about the kde-core-devel