qt-copy compilation problem on x86_64

Andras Mantia amantia at kde.org
Wed Sep 20 11:38:19 BST 2006

On Wednesday 20 September 2006 13:19, Thiago Macieira wrote:
> Andras Mantia wrote:
> >On Wednesday 20 September 2006 12:40, Thiago Macieira wrote:
> >> What does pkg-config --libs dbus-1 say?
> >
> >-ldbus-1
> Then the Qt buildsystem is not doing anything wrong. Your library was
> installed somewhere it shouldn't have, or there's a bug in D-Bus or
> pkgconfig.
> What does your /usr/lib/pkgconfig/dbus-1.pc say about libdir and
> libs?

well, I have two dbus-1.pc files, as I have both a 32 bit and 64bit dbus 
installed (common on 64 bit systems). 

 /usr/lib/pkgconfig/dbus-1.pc :

 /usr/lib64/pkgconfig/dbus-1.pc :

This is similar what was solved in the KDE 3 buildsystem, where you have 
to find out somehow where are the standard architecture libraries. They 
can be in "lib", "lib64" or even "lib32" IIRC. I don't know if this can 
be solved using pkg-config or not. 
"export PKG_CONFIG_PATH=/usr/lib64/:$PKG_CONFIG_PATH" doesn't change the 
output of "pkg-config --libs dbus-1".


Quanta Plus developer - http://quanta.kdewebdev.org
K Desktop Environment - http://www.kde.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20060920/0e826492/attachment.sig>

More information about the kde-core-devel mailing list