[RFC] Solid and use of namespaces
glaurent at telegraph-road.org
Sun May 21 16:22:35 BST 2006
On Sunday 21 May 2006 16:50, David Faure wrote:
> The difference is that in a .cpp file you can do
> using namespace Power;
> Manager(...); Battery::isFilled();
> which avoids filling the file with "Power" everywhere.
Yes, but it doesn't necessarily make for more readable code, especially when
the class name degrades to something very generic without the namespace,
like "Object" or, as you chose yourself, "Manager". When such code is mixed
with other libs which have similarly named objects, it doesn't look good.
More information about the kde-core-devel