kdirlister and friends
faure at kde.org
Wed May 17 09:19:32 BST 2006
On Tuesday 16 May 2006 23:41, Jens Herden wrote:
> 1. I would move KDirListerCache::validURL into the KDirLister class because it
> is not working with any data from KDirListerCache.
> 2. I see many places where lister->d-> is used in KDirListerCache to access
> the private data in the KDirLister. I guess it would speed up things a little
> if the pointer to the private data would be cached, right? IMHO this would be
> also more readable.
I seriously doubt that this will make any performance difference.
> 3. I wonder if the code for filtering could get removed from KDirLister. [...]
This sounds fine to me at first sight.
> 4. void setAutoErrorHandlingEnabled( bool enable, QWidget *parent );
> should change to
> void setAutoErrorHandlingEnabled( bool enable, QWidget *parent = 0);
Well, if enable==true, a parent widget is really wanted, for message boxes to have a proper parent.
But if it's false then of course it's not needed... Hmm. OK then.
> 5. A minor wish would be to rename the property autoErrorHandlingEnabled to
> just autoErrorHandling. This would shorten the name a bit without loosing the
> meaning and it is also consistent to the other bool properties which do not
> feature the 'Enabled' in the name.
The name is consistent with the KIO::Job method of the same name, so if one
should be changed, they should both be changed. Maybe someone from Trolltech
can advise us on the naming? They're the experts in that area ;-)
David Faure, faure at kde.org, sponsored by Trolltech to work on KDE,
Konqueror (http://www.konqueror.org), and KOffice (http://www.koffice.org).
More information about the kde-core-devel