Error building latest snapshot

David Jarvie lists at
Mon May 15 09:44:53 BST 2006

On Monday 15 May 2006 9:32, David Faure wrote:
>On Saturday 13 May 2006 01:10, David Jarvie wrote:
>> On Wednesday 10 May 2006 11:21, David Faure wrote:
>> > > QMAKESPEC has not been set, so configuration cannot be deduced.
>> >
>> > Looks like a qmake problem. Can you compile qt examples?
>> Yes, from within the qt-copy source tree. I've tried setting QTDIR to my Qt 
>> source tree for building the snapshot, but the same error occurs. 
>I don't think that works if you didn't specify --prefix=$PWD to configure.
>Qt expects to be installed, then.
>> I copied the latest cmake/modules/*.cmake 
>> from the snapshot into cmake's modules directory.
>Why? This isn't necessary anymore. Please remove those, they will remain used above
>any later updates to those files in kdelibs. kdelibs uses its own modules directly,
>and make install in kdelibs installs them for other modules. No manual copying

The conclusion of this problem is discussed in the thread with subject "kdelibs build fails 
with installed Qt". The change which has occurred appears to be that extra Qt install 
targets are now needed when installing Qt.

David Jarvie.

More information about the kde-core-devel mailing list