Building with cmake

Andras Mantia amantia at
Mon Mar 20 19:23:29 GMT 2006

On Monday 20 March 2006 21:09, William A. Hoffman wrote:
> At 01:21 PM 3/20/2006, Andras Mantia wrote:
> >On Monday 20 March 2006 18:15, Laurent Montel wrote:
> >> Not a good idea
> >> Use
> >>
> >>
> >> It works with it.
> >
> >Ok, this is exactly the problem Cristian Tibirna brought up in the
> > "my little tooth on cmake" thread. I just tried to build KDE at
> > random time following the suggestions and I couldn't because cmake
> > from today does not work, but from 3 days ago works. And cmake from
> > CVS was recommended instead of the last release.
> > I really hope that soon we will see a release which can be used for
> >KDE. Now I will get the tarball you've suggested.
> So, 2.3.4 is known to work.  CVS Head should work.  It might be
> helpful if you posted the problem you are having.  

It was included in my first mail, but...forget it, I updated the 
kdelibs4_snapshot, but not the kdelibs and tried to compile the trunk 

Still there are some issues. I have qt4 in a non-standard dir and even 
if I added the qt4/bin to PATH, I had to use 

as a cmake option, otherwise it gave me this error
QT_QMAKE_EXECUTABLE set to qmake version: QTVERSION = **Unknown**
QT_QMAKE_EXECUTABLE = /usr/lib/qt3/bin/qmake, please set to path to 
qmake from qt4.
Qt qmake NOT found!

And I still don't have a Makefile, most probably because of this:
-- Found ASPELL: /usr/lib64/
Could NOT find GIF
-- Configuring done

Here is a request: if there is an error, please tell that this is an 
error and not just "done".

So, is there something like the config.log which tells me what test was 
failed? I want to know what does that "Could NOT find GIF" means and 
how serious the error is.

Quanta Plus developer -
K Desktop Environment -
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <>

More information about the kde-core-devel mailing list