KCM rename

Friedrich W. H. Kossebau Friedrich.W.H at kossebau.de
Wed Jul 19 15:45:35 BST 2006

Am Mittwoch, 19. Juli 2006 11:02, schrieb Matthias Kretz:
> Hi,
> as KCModule and friends are not bound to KControl anymore I believe a
> rename of the classes is in order. In Trysil Aaron and Ben said to call
> everything KSettings:
> KCModule -> KSettingsModule or KSettingsPlugin
> KCModuleInfo -> KSettingsInfo(rmation)
> KCModuleProxy -> KSettingsWidget
> KCMultiDialog -> KSettingsDialog
> KSettings::Dialog -> KSettingsDialog
> KSettings::CompontentsDialog -> KSettingsDialog
> KCModuleContainer -> KSettings(Module|Plugin)Container
> Another obvious name would be to use Config, but KConfig is already taken.
> I'm not satisfied with the name change yet and before I'd tackle such a
> drastic change I'd like to hear some more opinions.

But what is the semantic difference between config and setting? Why is that 
stuff called config in one place and setting in another? Looks strange to me.

Aren't those classes above not simply the view and control thingies + 
framework to the config/setting model? 
And who forbids renaming the existing KConfig in the same move? ;)

Summary: What about a glossary for consistent naming in the KDE api?


More information about the kde-core-devel mailing list