Thiago Macieira thiago at kde.org
Sat Jul 8 08:20:12 BST 2006

David Faure wrote:
>I talked to Marius about adding an annotation in the xml for this, but
> he's not really convinced and I have to admit that I'm not either; it's
> an implementation detail of the adaptor, irrelevant to the clients of
> that interface. Maybe this should be done on the dbusxml2cpp
> command-line somehow, or with a separate file...

This is not a bad solution, actually.

There are two kinds of annotations, basically: those that are needed to 
generate the static class (either the interface or the adaptor) and those 
that are needed during run-time. Both are <annotation>.

We already have both kinds in the QtDBus implementation. There's a nifty 
trick that allows one to change the names of the getter and setter 
methods of properties (so you get isEnabled/setEnabled, for instance). 
Those annotations are purely generation-time and bear no impact on 
run-time. However, the annotation that carries the Qt type name is 
required at run time.

So, adding this annotation with value="true" isn't a bad idea.

  Thiago Macieira  -  thiago (AT) macieira.info - thiago (AT) kde.org
    PGP/GPG: 0x6EF45358; fingerprint:
    E067 918B B660 DBD1 105C  966C 33F5 F005 6EF4 5358
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 191 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20060708/bbc318f7/attachment.sig>

More information about the kde-core-devel mailing list