KStandardDirs::checkAccess, ::mkdir, etc

Stephan Kulow coolo at kde.org
Thu Jul 6 10:07:46 BST 2006


I looked at the header of KStandardDirs and I wonder if someone
has a good name for the namespace of the non-standard dir functions
that happened to move into it.

I'm talking about ::mkdir, ::checkAccess, ::exists, ::realPath 
and ::realFilePath (even though I wonder why would need two functions 
for that)

The suggestions on #kde4-devel were KDirHelper and KFileSystem. What
do you think?

Greetings, Stephan

More information about the kde-core-devel mailing list