RFC: kdDebug() -> kDebug()

Nicolas Goutte nicolasg at snafu.de
Sun Jan 29 15:04:06 GMT 2006

On Saturday 28 January 2006 15:36, Stephan Kulow wrote:
> Hi!
> I would like to remove some stupidness from our API: the d between k
> and Debug() and wonder what others feel about it taking that it will
> require some changes in the code :)
> The reason it's there is that kDebug() was already taken by a function
> basically replacing qDebug() - but as this function is gone, I'd like to
> change that for KDE4. What do you think?

I think it would be good that the name of the include file and the name of the 
main function matches, be it in one direction or the other.

The only problem I see is that there are many of these kdDebug/kdWarning calls 
in KDE, including many hidden in comments. So perhaps we must be careful when 
deciding to remove the KDE3 names.

> Greetings, Stephan

Have a nice day!

More information about the kde-core-devel mailing list