which compilers do we want to support with KDE 4 ?

Olaf Jan Schmidt ojschmidt at kde.org
Sat Jan 21 12:41:18 GMT 2006

[ Albert Astals Cid ]
> Be a bit agressive now and ask for gcc 4.0.x or similar capable compilers
> for KDE 4.x because KDE 4 will be around for quite time (maybe 3 years?)
> And i'm sure in 3 years time noone will be even be using gcc 4.0.x so why
> should we keep supporting gcc 3.2?

All LSB 3.0-compliant distributions will need to ship Qt >= 4.1, compiled with 
gcc 3.4, because gcc 4.0 is not fully backwards compatible. If we want KDE 4 
to work on these systems, then we need to support gcc 3.4 as well.


Olaf Jan Schmidt, KDE Accessibility co-maintainer, open standards 
accessibility networker, Protestant theology student and webmaster of 
http://accessibility.kde.org/ and http://www.amen-online.de/

More information about the kde-core-devel mailing list