RFC: KWizard
Olivier Goffart
ogoffart at kde.org
Thu Aug 3 22:17:59 BST 2006
Le jeudi 3 août 2006 21:51, Thomas Zander a écrit :
> On Thursday 3 August 2006 20:49, Olivier Goffart wrote:
> > Here is an attempt to replace Q3Wizard
> >
> > It's basically just a simple KPageDialog with "Back" and "Next" Buttons
>
> A wizard should have more features then this to be in kdelibs IMOHO.
> Do you plan to extend it?
>
>
> I'm missing things like:
> Several hooks:
> protected:
> /// Called when entering a page, usefull to setup the data for that
> page virtual void enteringPage(QWidget *to, bool usingNext);
> /// Called when leaving a page.
> virtual void leavingPage(QWidget *from, bool usingNext);
> /// Called when leaving the wizard.
> virtual void leavingWizard(bool successfull);
That's not required, there is already virtual back() and next() (and
accept()
and there is the currentPageChanged (KPageWidgetItem *current, KPageWidgetItem
*before) signal.
> A standard feature or two for wizards:
> public:
> /// A page will only be shown when it is appropriate.
> bool isAppropriate(QWidget *page);
> /// the next page will only be shown when its verified to be correct
> bool isVerified(QWidget *page);
>
> /// A page will only be shown when it is appropriate.
> void setAppropriate(QWidget *page, bool appropriate);
> /// Alter the next button being enabled at the argument page.
> void setVerified(QWidget *page, bool verified);
the verified is already there under the name "setNextEnabled"
Anyway, "verified" is a better name, I'll change that
About appropriate, i was about to add it because it was in Q3Wizard, but i
don't know the sens of it.
Thanks for your feedback.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <http://mail.kde.org/pipermail/kde-core-devel/attachments/20060803/8f064531/attachment.sig>
More information about the kde-core-devel
mailing list